Back to overview
Degraded

Broadband Services

Nov 04 at 11:40am GMT
Affected services
LON2 Subscriber Services
Leased Lines (Ethernet Circuits)

Resolved
Nov 05 at 07:08pm GMT

Broadband services have been stable over the last 24 hours.

Updated
Nov 04 at 06:42pm GMT

We have seen a recurrence of the session & connectivity drop.

We have informed ICUK (the wholesale provider), who are currently working towards service restoration.

Updated
Nov 04 at 03:28pm GMT

All affected services are currently back online.

We are working with ICUK closely to mitigate any further impact.

Further updates will be provided as required.

Updated
Nov 04 at 03:00pm GMT

We are experiencing intermittent service as ICUK appears to be handling several denial-of-service attacks.

Further information will be provided as required.

Created
Nov 04 at 11:40am GMT

We are aware of a fault affecting broadband services via ICUK starting at 11:40 AM.

We will update this page as more information is available.